Monday, January 13, 2014

New Checkstyle idea: Appropriate Name Check

It is very ambition task but :) it will be good to have such Check to control typos and restrict non-English developers to write ease-to-read code.

Main focus on ensure that methods start  from verb, variable and Classes are nouns/adjectives (very difficult, separate vocabulary, ...... could be done as student diploma work).
As an option - Grammar validation for names of variables, methods, classes base on vocabulary - it will be very good experiment.

Attention for interesting Naming examples to consider for Class names and Boolean names:
AvoidStarImport - name started from verb.
allowByTrailComment - name started from verb - Boolean  variable , is there better name ?

so Check should be not that strict or rules for naming should be more complicated.

We could borrow spelling/grammar check from Eclipse.
Is there any other OSS library ?

Spell projects:

If you run to this page and share idea with me, please let me know.

No comments:

Post a Comment